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Disclaimer 

	 Trishear3D is distributed on an as is basis without any warranty, explicit or implicit. 
The author will not be liable for direct, indirect, incidental, or consequential damages 
resulting from any defect in this software or in this user's manual, even if he has been 
previously been made aware of the defect. Furthermore, I make no systematic effort to 
inform all users of either bug fixes or upgrades. This program may not be sold or offered 
as an inducement to buy any other product.


	 Trishear3D is free for academic, non-profit purposes. If you want to use the 
program for commercial purposes, please contact me at nestor.cardozo@uis.no.


Referencing this program 

	 Please reference the program as: Trishear3D by Nestor Cardozo. Also, add the 
following reference in any publication or presentation:


Cardozo, N. 2008. Trishear in 3D: Algorithms, implementations and limitations. Journal of 
Structural Geology 30, 327-340.


Credits 

I would like to thank Ernesto Cristallini from sharing his ideas and his code about 
trishear in 3D. Ernesto designed brilliant solutions for both pseudo 3D and true 3D 
trishear. I would also like to thank Richard Allmendinger for sharing his knowledge and his 
code about trishear. Rick implemented the most versatile computer program for trishear 

in 2D: FaultFold. Trishear3D is inspired on FaultFold.


	 Trishear3D is a Cocoa application written in Objective C. The program would have 
not been possible without the OpenGL library and the excellent OpenGL tutorials on the 
web, specially Nehe Productions.
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Introduction 

Trishear3D is a program to run 3D trishear models. Trishear is a kinematic model 
of fault-propagation folding in which the decrease in displacement along the fault is 
accommodated by heterogeneous shear in a triangular zone radiating from the tip line. 
Several publications describe the trishear model in 2D, including Erslev (1991), Hardy and 
Ford (1997), Allmendinger (1998), and Zehnder and Allmendinger (2000).


	 Trishear can be extended to 3D by solving either a series of 2D sections parallel to 
the slip vector (pseudo-3D trishear, Cristallini and Allmendinger, 2001), or a true-3D 

formulation (Cristallini et al. 2004). Trishear3D uses either one of these algorithms.


	 With Trishear3D you can set up a 3D trishear model, run it, modify it (i.e. modify 
model parameters, add beds, start a new fault), and examine its geometry and finite strain 
(either in 3D, cross section, or tables). You can also construct fault bends and use 
backlimb kinematic models such as layer-parallel slip or inclined shear to make fault-bend 
folds (including rollovers). Geometry and strain data can be exported to fracture and 
reservoir modeling programs.


	 Trishear3D can do forward and reverse modeling. You can deform and restore 
surfaces. However, an inverse modeling routine such as those in Allmendinger (1998) 

or Cardozo (2005, 2009, 2011) is not implemented in the program. Trishear3D is a great 
tool to visualize the effect of spatial and temporal variations of faulting on the geometry 
and finite strain of fault related folds.


Basic interface 

	 When the program starts, it looks like Figure 1. The program's main window 
consists of three views: (i) A Plot view, (ii) a Table view, and (iii) a Log view. The Plot view 
displays the model in three-dimensions, the Table view lists the model's geometry and 
strain data, and the Log view is a record of the program's use. You can access any of 
these views using the tabs on top of the window, the Modules menu, or the keyboard 

combinations: ⌘1 for the plot view, ⌘2 for the table view, or ⌘3 for the log view.
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Plot view: 

	 The Plot view shows a white cube, a white arrow, and a triad (Figure 1). These 
objects indicate the reference coordinate system. You can toggle them using the Plot -> 

Reference Frame menus, or alternatively typing ⌥⌘B to toggle the cube, or ⌥⌘A to 

toggle the arrow and the triad. The reference coordinate system of Trishear3D is a right 
handed Cartesian coordinate system with X increasing to the east, Y increasing to the 
north, and Z increasing upward. The triad at the center of the cube indicates the 
orientation of the axes: the red line is parallel to the X axis, the green line to the Y axis, 
and the blue line to the Z axis. The white arrow points towards the positive Y axis (north). 
The ticks and labels at the sides of the cube indicate the model dimensions.
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Figure 1. Trishear3D main window and the Plot view



	 The X, Y, and Z coordinates of any non-transparent, solid object in the Plot view 
can be obtained by clicking the object. The coordinates are shown in the text field at 
the upper right corner of the view (Figure 1). The zoom and orientation of the view can be 
modified using the following keyboard combinations:


	 You can also modify the Plot view using a three buttons mouse. To rotate the 
model, press the left mouse button and drag the mouse. To zoom the model, press the 
right mouse button and drag the mouse. To translate the model, press the middle mouse 
button and drag the mouse. The settings of the Plot view are shown in the middle text 
field above the plot. This field contains five digits corresponding to the zoom, azimuth, 
inclination, vertical, and horizontal translation, respectively (Figure 1). You can reset the 
default view values using the Plot -> View -> Reset menu or the keyboard combination 

⌥⌘R. The background can be changed from black to white (or vice versa) using the Plot 

-> View -> Background Black menu. By default the background is black. You can save the 
plot as a jpeg using the File -> Save -> Plot as jpeg menu or the keyboard combination 

⇧⌘S .


Table and log views 

	 The table view has two buttons at the base. These buttons are used to choose the 
bed/surface (left button), and the type of data: nodes or tetrahedrons (right button). You 
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⌘+ Zoom in

⌘- Zoom out

⌘→ Rotate model right

⌘← Rotate model left

⌘↑ Rotate model up

⌘↓ Rotate model down

⌥⌘→ Translate model right

⌥⌘← Translate model left

⌥⌘↑ Translate model up

⌥⌘↓ Translate model down



can also trigger these buttons using the Table menus or their corresponding keyboard 
combinations.


	 Every operation performed by the program is written to the log view. You can copy 
or drag results from the table or the log view to any application. You can save the table 

and the log as text files using the File -> Save -> Table as text (⌥⌘S), and File -> Save -> 

Log as text ( ^⌘S) menus. To learn more about the table and log views read the Tables 

and log section.


Preferences 

	 Key parameters of the program can be set through the Preferences panel: 

Trishear3D -> Preferences, or keyboard combination ⌘, (Figure 2).
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Figure 2. The Preferences panel



	 The parameters that can be set up in the Preferences panel are:


1. The extent of the beds in X and Y.


2. The size of the cells. Trishear3D undeformed beds are surfaces made of equal size 
quadrilaterals.


3. The type of backlimb kinematics, parallel or similar, and if the similar option is 
selected, the shear angle (see the Backlimb kinematics section). Notice that backlimb 
kinematics only works if fault slip is perpendicular to strike and Lateral fault 
propagation (point 7 below) is off.


4. The possibility to compute strain and the number of cells between tetrahedrons to 
compute strain. By default this option is off.


5. The option to use the pseudo-3D or the true-3D trishear algorithms. Please 
check Cardozo (2008) and the algorithms section to understand how these algorithms 
work. Use with caution the true-3D algorithm. It has some inconsistencies that make 
models questionable when the slip gradient along the fault is high and the tip line is 
oblique to the slip vector and/or to the fault strike (Cardozo, 2008). All models in this 
manual were made using the pseudo-3D algorithm.


6. The possibility to allow opposite slip along the fault. By default this option is off. This 
prevents interpolation ahead of fault tips. Toggle on this option if you want to model 
faults that change from reverse to normal along strike.


7. The possibility to model lateral (along strike) fault propagation. By default this option is 
off. This option can only be selected if the Opposite slip along fault option is off. To 
learn more about lateral fault propagation check Cardozo (2008) and the Lateral 
propagation section.


8. The possibility to use a symmetric, bilinear variation of parameters along the fault tip 
line from a point halfway from the fault to the fault tips. By default this option is off and 
the program uses a linear variation of parameters between the fault tips. This option 
only works in pseudo-3D models. To learn more about this, check the bilaterally 
growing fault example of the Lateral propagation section. 

	 If you change the preferences in the middle of a run, the model is deleted and the 
New Model panel (see Making a model section) shows up.
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Making a model 

	 To create a new model, open the New Model panel (Model -> New or keyboard 

combination ⌘N, Figure 3).


Input parameters 

	 A model is defined by the following parameters (Figure 3):


1. The strike and dip of the fault. Trishear3D uses a right-hand convention. In this 
convention, the fault dips to the right (+ 90°) of the input strike direction. The strike is 
an azimuth angle measured from the North (white arrow in Figure 1).


2. The trishear angle or apical angle of the triangular zone at the fault tips, or at the tips 
and at a point halfway the tips if the bilinear variation of parameters option is on.


3. The across-strike fault propagation to fault slip ratio (P/S) at the fault tips, or at the tips 
and at a point halfway the tips if the bilinear variation of parameters option is on.
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Figure 3. The New Model panel



4. The fault slip at the fault tips, or at the tips and at a point halfway the tips if the bilinear 
variation of parameters option is on. Use positive slip for reverse faults and negative 
slip for normal faults.


5. The rake or orientation of the fault slip vector with respect to the fault strike. The rake 
is measured clockwise from the strike direction and its value should be between 0 and 
180°. A rake of 90° corresponds to a slip vector perpendicular to the fault strike. 
Figure 4 shows a map view of two thrust faults (red rectangles) with strike and dip 
0/30 (left) and 180/30 (right). In both cases slip vectors with rake 30 and 150° are 

shown. If the rake is 0 or 180°, the fault is strike-slip. Strike slip faults cannot be 

modeled with the pseudo-3D algorithm. If you enter a rake of 0 or 180 in pseudo-3D 
mode, you will get a warning message and the rake will be deleted.


6. The number of slip increments (Incr). Trishear3D computes the deformation 
incrementally. You should use a number of slip increments that ensures a smooth 
geometry.


7. The XYZ coordinates of the fault tips. There are two options to define these 
coordinates: a. The tip line is horizontal and the tips are along the fault strike, and b. 
The tip line may not be horizontal and the tips are not necessarily along the fault strike. 
To select the first option, toggle on the Tips along strike button (Figure 3). You will 
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Figure 4. Map view of two thrust faults (red rectangles) with strike and dip 0/30 
(left) and 180/30 (right). In both cases, slip vectors with rakes 30 and 150 are 
shown.



need to enter the length of the tip line and the XYZ coordinates of the fault tip 1. The 
tip 2 is then computed from tip 1 along the strike direction. For clarity, the tip 1 is 
shown as a red dot on the fault plane in the plot view. Figure 4 shows the location of 
the tips 1 and 2 for thrusts with strike and dip 0/30 (left side) and 180/30 (right side). 
To select the second option, toggle off the Tips along strike button. In this case you 
need to input the XYZ coordinates of the tips 1 and 2. The length of the tip line is 
computed by the program. If the strike of the fault is not consistent with the 
coordinates of the tips, the program shows an alert message with the correct strike 
value and sets this value in the Strike field. If the tip line is horizontal, it is more 
convenient to use the Tips along strike option. This is because the fault strike, length 
of the tip line, and coordinates of the tip 1 define the coordinates of the tip 2.


8. The lateral or along-strike fault propagation to fault slip ratio (Lateral P/S). This field 
can only be edited if the Lateral fault propagation option in the Preferences is 
on and the slip is zero in one of the tips (or at both tips if a bilinear variation of 
parameters). Lateral fault propagation operates on the tip (or tips if a bilinear variation 
of parameters) that has zero slip. If the lateral P/S is greater than zero, the location 
along strike of the tip with zero slip will change as the structure grows, so that the 
length of the tip line will increase with deformation. To learn more about along strike 
fault propagation check the Lateral propagation section.


9. The option to start the fault from a decollement. If you choose the parallel shear option 
in the Preferences panel (see basic interface section), the ramp from the decollement 
should not have a dip higher than 30 degrees. If that is the case, you will get a warning 
message and the dip of the ramp will be set to 30 degrees (see Backlimb 
kinematics section). Notice that this option is only available if the fault slip is 
perpendicular to strike (rake = 90) and the Lateral fault propagation option in the 
Preferences panel is off.


10.The tops and dips of the beds. Before the deformation the beds strike parallel to the Y 
axis. Positive dips are down to the negative X axis, and vice versa. In Figure 3 the 
beds dip 5 degrees down to the negative X axis.


11.Finally the X and Y coordinates of the origin of the layers.


Variation of parameters along the fault 

	 Trishear3D assumes a linear variation of the P/S, trishear angle, and fault slip 
between the fault tips, or between the fault tips and the point halfway the tips if the 
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bilinear variation of parameters is on. The P/S, trishear angle, and fault slip at any node 
are computed based on this interpolation, even if the node is outside the extent of the 
fault. For example, if the fault slip is 100 units at the tips (i.e. constant slip) and the fault 
does not cover the entire beds, the slip at the nodes not covered by the fault is 100 units, 
not zero. This ensures continuity. 

	 If the Opposite slip along fault option is off (see interface section), the fault can't 
have opposite slip along strike. If you enter opposite slip values at the tips (or at the tips 
and at the point halfway the tips), the model will not be created and an error message will 
be displayed. Toggling off the Opposite slip along fault option also ensures that the 
program does not interpolate beyond a fault tip. Along strike nodes beyond the tip will 
have zero displacement. This is crucial for the lateral fault propagation algorithm.


	 You won't be able to change the dip of the fault (ramp angle) along its strike. 

Trishear3D can only model fault propagation folding ahead planar faults. Backlimb 
folding due to non-planar, multi-bend faults can be modeled using simple kinematics 
such as layer parallel slip or inclined shear (see Backlimb kinematics section).


Refined models with several tips between end tips 

	 In pseudo-3D non laterally propagating models, you can introduce as many tips as 
you want between the end tips (tips 1 and 2 in Figure 3) using the Refine Model panel. At 
each of these tips, you can define the P/S, trishear angle, and fault slip. These parameters 
will vary linearly between the tips. This way, you can approximate any variation of P/S, 
trishear angle or fault slip along the fault using piecewise linear functions (see the 
example in the Refining a Model section).


	 Notice that in the New Model panel you can only set the parameters at the end 
fault tips (tips 1 and 2 in Figure 3). If there are several tips between the end tips from a 
previous run and you create a new model, the program will ask if you want to reuse these 
tips. In addition, if you want to modify the values of the parameters at these tips, you 
can use the Refine Model panel.


The new model 
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	 Once you fill the fields of the New Model panel, click the Okay button. A progress 
panel will appear. Please wait until the progress panel disappears to continue using the 
program. For the example of Figure 3 the initial model looks like Figure 5a.


	 Examine the model from different viewpoints. Toggle on and off the fault (Plot -> 

Fault or keyboard combination ⌥⌘F). Toggle on and off the trishear zone (Plot -> Trishear 

zone or keyboard combination ⌥⌘Z). Toggle on and off the View -> Filled option (⇧⌘O) 

to see the model in filled or wireframe mode. Change the transparency of the fault, 
trishear zone, or beds using the Plot -> View -> Transparency menus. Open the light 

panel (Plot -> View -> Light or keyboard combination ⇧⌘L) and change the light 

settings.


	 If the Calculate Strain option is on, tetrahedrons spaced by the number of cells 
specified in the Preference panel, will be created. If this is the case, toggle on and off the 

tetrahedrons using the Plot -> Strain -> Tetrahedrons menu (⌥⌘T). Toggle on and off the 

ellipsoids (they should all be spheres) using the Plot -> Strain -> Ellipsoids menu (⌘0), or 

the principal axes of strain (they should all have the same length) using the Plot -> Strain 

-> Principal axes menu (⌥⌘0). Figure 5b shows the tetrahedrons in the initial model. 

Running a model 
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Figure 5. Initial model from Fig. 3, without (a) and with (b) tetrahedrons



	 To run a model use the Model -> Run menu or type the keyboard combination 

⌘R . A progress panel will appear. Please wait. When the run is finished, the program 

updates the plot, table, and log views. Figure 6a shows the model of Figure 5 after 
running.


	 The current values of the model parameters are shown below the plot. The 
parameters listed are the total slip, the total propagation, the strike and dip of the ramp, 
the trishear angle, the P/S, and the rake of the slip vector. The values of these parameters 
are shown at the fault tips, or at the fault tips and the point halfway these tips if using a 
bilinear variation of the parameters. The parameters and the coordinates of the fault tips 
are also shown in the Log view. 

	 The Run menu plots the model at the end the run. If instead you want to see the 
incremental deformation of the model, use the Model -> Run Incrementally menu or 

keyboard combination Shift-⌘-R. To run the model again, choose Model -> Run (⌘R). 

Figure 6b shows the model after the second run.


	 You may notice that at places where the fault cuts the beds, the beds look rather 
jagged. Modeling bed-fault intersections is not easy. In Trishear3D only the quadrilaterals 
that have all nodes on one side of the fault are drawn. Quadrilaterals whose diagonals 
have been stretched more than three times are not drawn either. In general fault-bed 
intersections improve by selecting a smaller slip increment.


14

Figure 6. Model of Figure 5 after (a) One run, (b) Two runs.



	 Trishear3D does not have Undo-Redo capabilities. However, a model with one 
ramp can be run backwards using the Model -> Run Backwards menu. This will 
retrodeform the model to its previous run step with a minor glitch: Quadrilaterals and 
tetrahedrons not showing (because they are cut by the fault) are not drawn in the restored 
state.


Modifying parameters 

	 The parameters of the model can be modified after a run using the Model -> 

Modify menu (⇧⌘M). The Modify model panel will show up (Figure 7).


	 In Figure 7, the fault slip was modified to 50 units at the tip 1, and the fault slip rake 
was modified to 70°. The backlimb kinematics section illustrates the use of the Modify 
model panel to construct multi-bend faults and fault-bend folds. Please notice that:


• It the Lateral fault propagation option in the Preferences panel is on, backlimb 
kinematics does not work and the ramp angle cannot be modified.


• If the fault has multiple bends (i.e. backlimb kinematics), the fault slip rake would be 
90° and it cannot be modified.


• If the Opposite slip along fault option in the Preferences panel is off and opposite slip 
values are entered, you will get an error message.


• If you are running a model with several tips between the end tips, you can use the 
Refine model panel to modify the values of the parameters at these tips.
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Figure 7. The Modify model panel.



Figure 8 shows the model after modifying the trishear parameters and running it.


Adding beds 

	 You can add beds after a run. This is a way to simulate growth strata. To add beds 

choose the Model -> Add beds menu or keyboard combination ⇧⌘A. The Add beds 

panel will show up (Figure 9). The panel shows the tops (the highest node) of the current 
beds. To add a bed simply fill one of the empty Tops boxes. You can also set the origin of 
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Figure 8. Model after modifying parameters and running it.

Figure 9. The Add beds panel.



the new bed. The extent of the new bed is taken from the Preferences (see Basic 

interface section).

	 Enter the top and origin of the new bed, click Okay. If you don't like the location of 
the new bed, open the Add beds panel again and modify the entries. You can do this with 
one or several new beds. Note that only horizontal beds above the lowest point of the 
youngest deformed bed can be added. Also, you can add beds up to a maximum of 10 
beds.


	 Trishear3D can model intersections (pinchouts) of new beds against the deformed 
beds, but not against irregular surfaces or faults. The algorithm computes bed 
intersections reasonably well. However, when a new bed intersects more than one 
deformed bed along strike, the algorithm does not work. Figure 10 shows the model after 
adding the bed number 6 of Figure 9 and running the model.


Starting a new fault 

	 To start a new fault choose the Model -> Start New Fault menu or keyboard 

combination ⇧⌘F. The New Fault panel will appear (Figure 11). Once a new fault is 

made, it will replace the previous fault. Older fault(s) are not considered or shown. You 
can see how the beds get deformed by the new fault, but no how older fault(s) get 
deformed by the new fault.
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Figure 10. Model after adding one bed and running it.



	 

	 Please notice that:


• If the Opposite slip along fault option is off and opposite slip values are entered, you 
will get an error message.


• In the New Fault panel you can only modify the end fault tips (tips 1 and 2). If there are 
several tips between the end tips of a current fault, the program will ask you if you 
want to use the intermediate tip locations for the new fault. If you want to modify these 
intermediate tips, you can use the Refine model panel.


• Ramp up from decollement only works if the fault slip rake is 90° and there is no lateral 
fault propagation.


	 Figure 12 shows the model after starting the new fault with the parameters of 
Figure 11 and running it.
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Figure 11. New Fault panel.



Saving and opening a model 

	 To save a model use the File -> Save -> Model menu or keyboard combination ⌘S. 

A progress panel will show up. Please wait. Trishear3D models are saved as files with 
extension trish. To open a model use the File -> Open menu or keyboard combination 

⌘O. A progress panel will show up. Please wait.


Visualizing a model 

	 There are several options to visualize the geometry and strain of models.


Selective display of beds 

	 Often you would like to display on/off some beds. Let's take as example the model 
of Figure 8:


1. Highlight the currently selected bed using the Plot -> Beds -> Show Selected menu 

(⌘\). A thick line around the bed will show up.


2. Move up or down to the bed you want to select using the Plot -> Beds -> Up or Down 

menus, or keyboard combinations ⇧⌘↑ and ⇧⌘↓, respectively. For example select 

the top bed (Figure 17 left).
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Figure 12. Model after making new fault and running it.



3. Draw (Plot -> Beds -> Draw or keyboard combination ⌘D), or not (Plot -> Beds -> 

Don't draw or keyboard combination ⇧⌘D) the bed. Figure 13 (right) shows the model 

with the selected bed not displayed.


	 Repeat this procedure for several beds. You can display all beds again using the 

Plot -> Beds -> Draw all menu (keyboard combination ⌥⌘L).


Coloring beds 

	 Beds (and irregular surfaces) can be colored by their height or displacement. To 
color the beds by elevation, select the Plot -> Beds -> Color -> By Height menu or 

keyboard combination ⌘[ . Figure 14a shows the model of Figure 8 colored by elevation.
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Figure 13. Selecting and toggling off uppermost bed

Figure 14. a. Beds colored by elevation. b. Beds colored by strain.



	 To color the beds by displacement select any of the Plot -> Beds -> Color -> By 
Displacement menus. Beds can be colored X, Y or Z displacement or displacement 
magnitude.


	 By default the limits for coloring the beds (and irregular surfaces) by height or 
displacement are the current minimum and maximum values. Fixed minimum and 
maximum values can be set using the Plot -> Beds -> Color -> Set Height & Displ. Limits 
menu.


	 If the Calculate Strain option is on, the beds can be colored by the magnitude of 
finite strain. Select the Plot -> Beds -> Color -> By Strain menu or keyboard combination 

⌘] . Figure 14b shows the model of Figure 8 colored by strain, specifically the maximum 

principal stretch.


	 Trishear3D uses a simple algorithm to color the beds by strain. Each node is 
assigned a strain value based on the values and distances to the four tetrahedrons 
closest to the node. Thus, the quality of the strain contours depends on the number of 
tetrahedrons and their spacing.


	 You can set the strain parameter to plot, and the minimum and maximum contour 

values using the Plot -> Strain -> Set parameter menu or keyboard combination ⌘. . This 

will open the Strain Parameter panel (Figure 15).
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Figure 15. Strain Parameter panel.



	 To get a scale bar like those in Figure 14, select the Plot -> Scale bar option or 

keyboard combination ⌘/. You can drag the scale bar to any application or the desktop 

to save it as a pdf.


	 You can also modify the color map. Select the Plot -> View -> Color Map menu or 

keyboard combination ⌥⌘M. The Color Map panel will show up. For example, try 

coloring the beds by height (Figure 14a) using the Elevation color map. 

Tetrahedrons, ellipsoids and principal strain axes 

	 To plot tetrahedrons select the Plot -> Strain -> Tetrahedrons menu or keyboard 

combination ⌥⌘T . To plot ellipsoids select the Plot -> Strain -> Ellipsoids menu or 

keyboard combination ⌘0. To plot principal strain axes select the Plot -> Strain -> 

Principal axes menu or keyboard combination ⌥⌘0. The tetrahedrons or ellipsoids are 

colored by strain. The principal strain axes are colored red, green and blue for the 
maximum, intermediate and minimum principal axes, respectively. Figures 16 shows one 
bed with tetrahedrons (a) and ellipsoids (b).


Querying the plot view 

	 There are four ways to query the Plot view: 

1. By clicking any solid, non-transparent object in the view. The coordinates of the object 

will show up in the text field at the upper right corner of the view. 
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Figure 16. Bed with (a) tetrahedrons, and (b) ellipsoids.



2. By opening the Bed Info panel (Model -> Get Bed/Surface Info or keyboard 

combination ⇧⌘B). 


3. By opening the Strain Info panel (Model -> Get Strain Info or keyboard combination 

⇧⌘E).


4. By opening the Cross Section panel (Model -> Cross Section or keyboard combination 

⇧⌘X). 

The Bed Info panel 

	 The Bed Info panel (Model -> Get Bed/Surface Info or keyboard combination 

⇧⌘B, Figure 17) reports key parameters of the selected bed, specifically its: (i) lowest 

node, (ii) highest node, (iii) area, (iv) volume with respect to a datum, and if the strain is 
computed (v) the bed's maximum stretch, (vi) minimum stretch, and (vii) dilation.


	 The area of the bed is computed by adding the area of the quadrilaterals that have 
not been segmented by the fault. The volume with respect to a datum is computed by 
adding the product of the quadrilaterals area times their height to a datum. This is a 
convenient way to compute the volume between two beds. For example, if you want to 
compute the volume between two beds, compute the volume of each bed to the same 
datum. The volume between the beds is the difference of the computed beds' volumes.


	 The strain parameters are based on the tetrahedrons that have not been 
segmented by the fault. The bed’s dilation is the sum of the dilation of the tetrahedrons. 
The bed information is updated after running a model. This is a nice way to see how the 
parameters of a bed change with deformation.
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Figure 17. The Bed Info panel.



The Strain Info panel 

	 The strain of any tetrahedron or ellipsoid can be queried in the Plot view using the 

Strain Info panel (Model -> Get Strain Info or keyboard combination ⇧⌘E, Figure 18). 

Open the Strain Info panel and click any tetrahedron or ellipsoid in the view. The principal 
stretches and the bedding at the tetrahedron or ellipsoid location are plotted in an equal 
angle, lower hemisphere stereonet. The magnitude and orientation (trend and plunge) of 
the principal stretches, and the strike and dip (right hand rule convention) of bedding, are 
written below the stereonet. These elements can be toggled using the buttons below the 
stereonet. The Strain Info panel updates every time a new tetrahedron or ellipsoid is 
clicked. This is great way to explore the variation of strain across the structure.


The Cross Section panel 

	 To make a section across the model open the Cross Section panel (Model -> Cross 

Section or keyboard combination ⇧⌘X, Figure 19a). To define the section plane, you 

need to enter the following parameters: (i) The strike of the plane, (ii) the dip of the plane, 
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Figure 18. Strain Info panel after clicking one ellipsoid in the overturned forelimb of the 
bed in Figure 16.



(iii) The length of the plane along its strike, (iv) The length of the plane along its dip 
direction, and (v) the XYZ coordinates of the upper corner of the plane. Click the Update 
button. 


	 The section plane is drawn in gray in the Plot view. The upper corner of the section 
plane is indicated by a red dot, and the lower corner by a green dot (Figure 19b). The 
cross section is drawn in the panel (Figure 19a). Like in the 3D view, the upper and lower 
corners of the section plane are shown by a red and a green dot, respectively. The origin 
of the cross section is at the lower corner of the section plane (green point, Figure 19a). 
The abscissa of the cross section increases from the origin to the right and its extent is 
equal to the length of the section plane along its strike. The ordinate increases from the 
origin up and its extent is equal to the length of the section plane along its dip direction. 
The beds are drawn as black lines, and the fault as a red line.


	 When making a cross section it is important to remember that every bed is made 

of nodes spaced at finite distances. To draw the cross section, Trishear3D converts the 
nodes to a local coordinate system X'Y'Z', with X' parallel to the strike of the section, Y' 
parallel to the dip of the section, and Z' normal to the section plane. The program then 
plots in the section, the nodes with an absolute value of Z' lower than a defined width 
across the section plane, and within the X', Y' limits of the section plane. By default nodes 
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a. b.

Figure 19. Cross Section panel and section plane in Plot view.



with an absolute value of Z' lower or equal than the undeformed cell size are plotted in 
the cross section.


	 Sometimes in a cross section a bed is not a single line but several lines. In this 
case the width across the section might be too high. You can change the width using the 
slider at the lower right corner of the panel (Figure 19a). It can be reduced down to 0 (i.e. 
only nodes that are exactly at the section plane are plotted), or increased up to twice the 
cell size. In the cross section, adjacent points that are a distance lower than twice the 
average distance between all adjacent points are joined by a line, otherwise a new line is 
started.


	 You can drag the contents of the Bed Info, Strain Info, or Cross Section panel to 
any application. Dragging the stereonet (Figure 18) or cross Section (Figure 19a) to the 
desktop creates a pdf.


Refining a model 

In the pseudo-3D model, the solution coordinate system is associated to the fault 
slip vector. Thus, contrary to the true-3D formulation, in pseudo-3D the solution 
coordinate system is not attached to the tip line and does not rotate with deformation 
(Cardozo, 2008). This makes possible to implement in pseudo-3D any kind of variation of 
trishear parameters (P/S, trishear angle, and/or fault slip) along the fault tip line. In 
pseudo-3D mode, complex, non-linear variations of parameters along the tip line can be 
introduced using the Refine Model panel (Model -> Refine, Figure 20).


	 The Refine Model panel contains a table with the tips and their parameters, and 
buttons to add or delete intermediate tips (Figure 20). The table contains five columns: A 
tip column, with the ids of the tips. This column cannot be edited. A location column with 
the location of the tips expressed as the ratio: (distance from tip 1 along tip line) / (tip line 
length). The tip 1 has therefore a location value of 0.0 and the tip 2 a location value of 1.0. 

Any tip between the end tips 1 and 2 should have a location between 0.0 and 1.0 (in fact 
you will only be able to enter values between 0.0 and 1.0 in the location column). The last 
three columns are for the P/S, trishear angle, and fault slip at the tips. The trishear angle 
should be entered in degrees.
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	 The first two rows in the table of the Refine Model panel, correspond to the end 
tips 1 and 2. These rows cannot be edited or deleted. The only way you can modify the 
parameters at the end tips is through the New Model (Figure 3), Modify Model (Figure 7), 
or New Fault (Figure 11) panels. After creating a new model, you can add (or delete) as 
many tips you want. Once the model is run, these tips cannot be deleted. You will still be 
able to modify the P/S, trishear angle, and/or fault slip at the intermediate tips in the 
Refine Model panel. To modify these parameters at the end tips, you should use the 
Modify Model panel (Figure 7).


	 As an example, create a new model with the default values of the program. Make 
sure that in the Preferences panel, the pseudo-3D option is on, and the lateral 
propagation and bilinear variation of parameters options are off. Open the Refine Model 
panel. Add the following tips to the panel before running the model:


Tip Location P/S Trish. angle Slip

3 0.04 1.5 60 139

4 0.08 1.5 60 155
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Figure 20. The Refine Model panel.



	 The slip between the end tips varies in an elliptical, symmetrical manner from 100 
at the end tips to 200 at the mid tip. Run the model. The uppermost bed colored by 
elevation should look like Figure 21. The possibilities offered by the Refine Model panel 
are endless. You can approximate any variation of P/S, Trishear angle, and/or fault slip 
along strike using this panel.


Lateral propagation 

	 Trishear3D can model fault growth along strike. To do this, you need to toggle on 
the Lateral fault propagation option in the Preferences panel (Figure 2). Notice that this 
option can only be selected if the Opposite slip along fault option is off.


5 0.12 1.5 60 165

6 0.16 1.5 60 173

7 0.2 1.5 60 180

8 0.24 1.5 60 185

9 0.28 1.5 60 190

10 0.32 1.5 60 193

11 0.36 1.5 60 195

12 0.4 1.5 60 198

13 0.44 1.5 60 199

14 0.5 1.5 60 200

15 0.56 1.5 60 199

16 0.6 1.5 60 198

17 0.64 1.5 60 195

18 0.68 1.5 60 193

19 0.72 1.5 60 190

20 0.76 1.5 60 185

21 0.8 1.5 60 180

22 0.84 1.5 60 173

23 0.88 1.5 60 165

24 0.92 1.5 60 155

25 0.96 1.5 60 139
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Laterally growing faults 

	 Make sure that in the Preferences panel, the Lateral fault propagation option is on. 
Create a model with the following parameters (Figure 22):
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Height

250.00

350.00

Figure 21. Elliptical variation of slip along the fault. Bed is colored by elevation.

Figure 22. New model with lateral fault propagation.



	 The fault slip varies from 200 units at the tip 2, to zero at the tip 1. The initial length 
of the fault along strike is 50 units and the along-strike, lateral fault propagation to fault 
slip ratio (P/S) is twice the across-strike P/S. You can only edit the lateral P/S field if the 
slip at one tip is zero. Lateral fault propagation works such that the tip with zero slip 
moves along strike as the structure grows, so that the along-strike length of the fault 
increases with deformation. Run the model, you should get a geometry like Figure 23a.


	 The fault grew along strike in the positive Y (north) direction, and the elevation is 
higher at the location where the fault accumulated more slip. Let's start another fault on 
the opposite side, but growing along strike in the opposite direction (south). Open the 

New Fault panel (⇧⌘F). Fill the fields of the panel as in Figure 24.
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a. b.

N

Figure 23. a. Lateral fault propagation to the North. b. A new fault propagating in the 
opposite direction.

Figure 24. Second fault propagating to the negative Y (south) direction.



	 Fault slip varies from 200 units at the tip 1 to zero at the tip 2. The initial length of 
the fault along strike is 50 units and the lateral, along-strike P/S is twice the across-strike 
P/S. The tip 2 will move to the south (negative Y), so that the fault length will increase as 
slip accumulates. Run the model. You should get a geometry like in Figure 23b.


Bilaterally growing faults 

	 Let's model a fault that propagates along strike in two, opposite directions. Open 
the Preference panel and turn on the Lateral fault propagation and the Bilinear variation of 
parameters options. Now, create a model with the following parameters (Figure 25).


	 In this case the slip is zero at the tips and 100 units at the point halfway from the 
tips. The lateral P/S is six times the across strike P/S. The fault will propagate six times as 
much along strike as across strike. Each tip will propagate along strike, in opposite 
directions, three times as much as the propagation across strike. Run the model, you 
should get a geometry like Figure 26.
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Figure 25. New model for lateral fault propagation in two opposite directions.



 

Backlimb kinematics 

	 Trishear3D can model folding behind the trishear zone using simple kinematics 
such as inclined and parallel shear. These algorithms are based on a two-dimensional 
velocity formulation (Hardy, 1995). Backlimb kinematics only works if fault slip is 
perpendicular to strike (rake = 90°) and the Lateral fault propagation option is off. Also the 
kink axes of backlimb kinematics and the trishear zone should not cross. There are some 
interesting things you can do in Trishear3D using backlimb kinematics:


Ramp from decollement 

	 Create a model using the following parameters (Figure 27a). Make sure Parallel 
backlimb kinematics in the Preferences panel is on. You should get a model like Figure 
27b. Toggle the fault kink using the Plot -> Fault kinks menu or keyboard combination 

⌥⌘K. Run a model with variable slip along the fault. Change the backlimb kinematics to 

inclined shear. Use different shear angles.
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Figure 26. Bilateral fault propagation after one run. The bed is coloured by elevation.



Fault bend folding 

	 Trishear3D can generate a fault bend fold. The trick is to think about how fault 
bend folds form: first the fault trajectory is formed with very little slip, and then the 
hanging wall slips over the multi-bend fault plane. To generate the fault trajectory with 
little slip use a large propagation to slip ratio (P/S). Create a model using the parameters 
of Figure 28a.
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a. b.

Figure 27. Ramp from decollement. a. New model, and b. Model after one run.

a. b.

c.

Figure 28. Steps to produce a fault-bend fold.



	 The P/S is very high (150), the slip is small (1), and there is only one slip increment. 
Also the ramp up from decollement option is selected. Run the model. You are creating 
the footwall ramp. The ramp should not dip more than 30°. Now modify the fault dip so 
that the fault is again parallel to the beds using the Modify panel (Model -> Modify or 

keyboard combination ⇧⌘M, Figure 28b). Run the model about five times so that the tip 

line is to the right of the beds. Now that the flat-ramp-flat fault geometry has been 
created, modify the slip and the P/S so that the hanging wall moves above the fault, as in 
Figure 28c. Run the model, Figure 29 shows the resultant fault bend fold.


	 Toggle the fault kinks. Trishear3D only shows the active fault kinks (i.e. axial 
planes across which material particles rotate). Continue running the model. You will see 
how the active axial kink in the ramp-upper flat intersection, change in orientation. This 
happens when the cumulative slip is equal to the ramp length. Compute strain. The strain 
is simple compared to trishear folds. Run the same model but now with variable slip along 
the fault.


Rollover 

	 Following the previous strategy, faults with multiple bends can be created. For 
example, a listric fault can be created by increasing the fault dip between runs using the 
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Figure 29. Fault-bend fold.



Modify panel. You can then move the beds over the listric fault. Figure 30 shows a rollover 
created by normal faulting over a listric fault, with inclined shear (Similar backlimb 
kinematics) and a shear angle of 30° (positive shear angles correspond to shear planes 
antithetic to the fault). The beds are colored by elevation. Run a similar model but with 
variable slip. Try also reversing the slip (fault inversion). Compute strain.


Irregular surfaces 

	 Irregular surfaces are defined by scattered points. These surfaces can be loaded 
from text files using the File -> Load Surface from text menu or keyboard combination 

⌥⌘O. The format of a surface text file is simple: The file should contain as many lines as 

the number of points lying on the surface, and each line should contain the X, Y and Z 
coordinates of each point. Entries on a line can be separated by tabs, commas, or 
spaces. There is no limitation in the number of points. 


	 A maximum number of 10 surfaces can be loaded. Irregular surfaces are different 
from beds because instead of being made of regular quadrilaterals as the beds, they are a 
cloud of points which can be displayed as a triangular mesh. Irregular surfaces are 
detached from the model's beds. They are by default active (i.e. deform with the beds) 
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Figure 30. Rollover produced by 30° inclined shear over listric normal fault.



and visible. These options can be modified for each surface using the Surfaces Controller 

panel: Model -> Surfaces Controller or keyboard combination ^⌘X (Figure 31a):


	 

	 Use the buttons in the Active and Display columns to activate/deactivate, or show/
don't show a surface. Irregular surfaces are displayed by default as cloud of points 
(Figure 31b). However, they can also be displayed as triangulated surfaces. Just select a 
surface and click the Triangulate button in the Surfaces Controller panel (Figure 31a). Use 
the Maximum Aspect Ratio field to set the maximum aspect ratio of the triangles. Use the 
Maximum perimeter/Average perimeter field to set the maximum perimeter of the triangles 

as a multiple of the average perimeter of all triangles. (Figure 31a). Trishear3D uses a 
Delaunay subroutine by Paul Bourke to triangulate surfaces. This works fine if there are no 
points with different Z but identical X and Y. If the surface is vertical or overturned, 
the triangulation may not be as nice and the program may crash.


	 There are two main limitations with irregular surfaces: (i) They cannot have 
tetrahedrons and therefore strain cannot be computed on them, and (ii) Beds-Irregular 
surfaces intersections are not checked. Irregular surfaces are a convenient way to model 
actual data (Figure 31b). You can load an actual surface, make it inactive, and experiment 
with different models to see how they fit the surface. Alternatively, you can make the 
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a. b.

Figure 31. a. Surfaces Controller panel, and b. Two surfaces from a 3D seismic cube in 
the Niger Delta (courtesy of Andreas Plesch).



surface active and run different models backward (Model -> Run Backwards menu), to 
see how the models restore the surface. This needs to be done by trial and error. There is 

no inverse modeling routine in Trishear3D such as in Cardozo and Aanonsen (2009) and 
Cardozo et al. (2011).


Tables and log 

	 You can review and export the information of a trishear model using the Table view 
(Figure 32). The use of this view is straightforward: (i) Choose the bed/surface to get 
information from using the left button at the base of the view, and (ii) Choose the type of 
information (nodes or tetrahedrons) using the right button at the base of the table. You 
can also perform these operations using the Table menus or their corresponding 
shortcuts.
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Figure 32. Table view showing the strain information for bed 4 of a model.



	 Navigate the table and get familiar with the type of information reported. For the 
Nodes option, the initial (Xi, Yi, Zi) and current (Xc, Yc, Zc) coordinates of each node, its 
displacements (uX, uY, uZ), and displacement magnitude (|u|) are reported. For the 
Tetrahedrons option, the current coordinates of the centroid of each tetrahedron (Xc, Yc, 
Zc), the magnitude and orientation (trend and plunge) of the principal stretches (Smax, Sint, 
Smin), and the dilation (the product of the principal stretches) are reported. Notice that in 
some rows the stretches in a tetrahedron are reported as NA. This corresponds to 
stretches greater than 5.0.


	 To sort the table by a column, click the header of the column. You can select 
several rows or columns, and drag them to any application. You can also save the table 
as text tab-delimited file using the File -> Save -> Table as text menu or keyboard 

combination ⌥⌘S.


	 Finally, every operation in Trishear3D is written to the log view. This is a nice way 
to keep a record of your work. As with the table view, you can select text in the log view 
and drag it to any application. You can also save the log using the File -> Save -> Log as 

text menu or keyboard combination ^⌘S .


Keyboard shortcuts 

General: 

Opening and saving a model: 

Preferences ⌘,

Help ⌘?

Hide Trishear3D ⌘H

Hide others ⌥⌘H

Quit ⌘Q

Open a model ⌘O

Save a model ⌘S

Save plot as jpeg ⇧⌘S

Save table as text ⌥⌘S
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Modules:


Creating and running a model:


Table:


Plot:


Save log as text ^⌘S

Load surface from text ⌥⌘O

Plot view ⌘1
Table view ⌘2
Log view ⌘3

Create a model ⌘N

Run a model ⌘R

Modify a model ⇧⌘M

Add beds ⇧⌘A

Start new fault ⇧⌘F

Get bed information ⇧⌘B

Get strain information ⇧⌘E

Cross section ⇧⌘X

Run incrementally ⇧⌘R

Surfaces controller ^⌘X

Select next bed ⌘>

Select nodes ⌘N

Select tetrahedrons ⌘T

Zoom in ⌘+

Zoom out ⌘-

Rotate model right ⌘→

Rotate model left ⌘←

Rotate model up ⌘↑

Rotate model down ⌘↓

Translate model right ⌥⌘→
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Translate model left ⌥⌘←

Translate model up ⌥⌘↑

Translate model down ⌥⌘↓

Toggle black background ^⌘B

Reset model position ⌥⌘R

Toggle filled or wired mode ⇧⌘O

Toggle fault transparency ⌘4

Toggle fault kinks transparency ⌘5

Toggle trishear zone transparency ⌘6

Toggle beds/surfaces transparency ⌘7

Open light panel ⇧⌘L

Open color map panel ⌥⌘M

Toggle axes ⌥⌘A

Toggle bounding box ⌥⌘B

Show selected bed ⌘\

Select bed above ⇧⌘↑

Select bed below ⇧⌘↓

Draw selected bed ⌘D

Don’t draw selected bed ⇧⌘D

Draw all beds ⌥⌘L

Don't color beds/surfaces ⌘*

Color beds/surfaces by height ⌘[

Color beds/surfaces by vertical displacement ⌘(

Color beds/surfaces by displacement magnitude ⌘)

Set fixed limits for height and displacement ⌘:

Color beds by strain ⌘]

Toggle fault ⌥⌘F

Toggle fault kinks ⌥⌘K

Toggle trishear zone ⌥⌘Z

Toggle tetrahedrons ⌥⌘T

Toggle ellipsoids ⌘0
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Algorithms 

	 The algorithms and implementation of Trishear3D are described in detail 
in Cardozo (2008). Below is a short summary of the algorithms.


Pseudo-3D trishear 

	 In the pseudo-3D algorithm (Cristallini and Allmendinger, 2001) a number of serial 
2D sections, all parallel to the fault movement plane, are solved. The fault movement 
plane is defined by the fault slip vector (x) and the pole to the fault (y) (Figure 33a). The 
velocity field in each section is computed in the local xy coordinate system, attached to 
the z axis (perpendicular to the fault slip vector) and with origin at the fault tip 1 (Figure 
33a). The equations used to compute the velocity field are those of the simplest trishear 
model: A symmetric trishear zone with vx linear in y (Zehnder and Allmendinger, 2000, 
their equations 2 and 6). 


Toggle principal strain axes ⌥⌘0

Set strain parameter and its limits ⌘.

Show color scale bar ⌘/
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Figure 33. Coordinate systems for the a. Pseudo-3D and b. 3D trishear models.



The orientation of the xyz local coordinate system remains the same as long as the 
direction of the fault slip vector does not change. Therefore it is not necessary to update 
the length of the tip line and the variation of parameters along the z axis.


True-3D trishear 

	 In the true-3D algorithm (Cristallini et al. 2004), a true 3D formulation is solved in a 
local coordinate system with x perpendicular to the fault tip line, y perpendicular to the 
fault plane, and z parallel to the fault tip line (Figure 33b).


	 The local xyz coordinate system is attached to the current location of the tip line. 
Therefore it is necessary to update the local xyz coordinate system, the length of the tip 
line, and the variation of trishear parameters along the z axis, every increment of slip. The 
equations of the true-3D algorithm are described by Cristallini et al. (2004), but as 
discussed by Cardozo (2008) there are some problems with this algorithm that can result 
in considerable volume changes. Please be cautious when using this algorithm.


Lateral fault propagation 

	 In the pseudo-3D model, lateral fault propagation is implemented by augmenting 
the distance between the fault tips according to the lateral P/S. Notice that the local 
coordinate system is not changed, but rather the distance between the tips. In the 
true-3D model, since the local xyz coordinate system is attached to the fault tip line, it is 
just necessary to move the tips according to the fault slip and the across and along-strike 
P/S, and update the xyz local system according to the new position of the tips.


Backlimb kinematics 

	 Backlimb kinematics is solved using the 2D velocity description of Hardy (1995). 
This formulation allows the computation of the velocity fields for both inclined shear, and 
mode I fault-bend folding (Suppe, 1983). Fault slip can be varied along strike. Variable 
fault slip, however, poses some problems in mode I fault-bend folding when in some 
sections the magnitude of the slip is equal or greater than the length of the footwall ramp, 
while in other sections it is lower. In this case the active and passive kinks that control the 
deformation (Suppe, 1983) may switch along strike.
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	 Backlimb kinematics can only be modeled if fault slip is perpendicular to strike 
(rake = 90°) and the Lateral fault propagation option in the Preferences panel is off. Also 
make sure that the kink axes of backlimb kinematics and the trishear zone do not cross.


References 

Allmendinger, R.W., 1998, Inverse and forward numerical modeling of trishear fault-
propagation folds. Tectonics, v. 17, p. 640-656.


Cardozo, N., 2005, Trishear modeling of fold bedding data along a topographic profile. 
Journal of Structural Geology, v. 27, p. 495-502.


Cardozo, N., 2008, Trishear in 3D: Algorithms, implementation, and limitations. Journal 
of Structural Geology, v. 30, p. 327-340.


Cardozo, N. and Aanonsen, S. 2009. Optimized trishear inverse modeling. Journal of 
Structural Geology, v. 31, p. 546-560.


Cardozo, N., Jackson, C.A. and Whipp, P.S. 2011. Determinining the uniqueness of 
best-fit trishear models. Journal of Structural Geology, v. 33, p. 1063-1078.


Cristallini, E.O. and Allmendinger, R.W., 2001, Pseudo 3-D modelling of trishear fault-
propagation folding. Journal of Structural Geology, v. 23, p. 1883-1899.


Cristallini, E.O., Giambiagi, L. and Allmendinger, R.W., 2004, True three-dimensional 
trishear: A kinematic model of strike-slip and oblique-slip deformation. Geological Society 
of America Bulletin, v. 116, p. 938-952.


Erslev, E.A., 1991, Trishear fault-propagation folding. Geology, v. 19, p. 617-620.

Hardy, S., 1995. A method for quantifying the kinematics of fault-bend folding. Journal 

of Structural Geology, v. 12, p. 1785-1788.

Hardy, S. and Ford, M., 1997, Numerical modelling of trishear fault-propagation folding. 

Tectonics, 16, 841-854.

Suppe, J., 1983. Geometry and kinematics of fault-bend folding. American Journal of 

Science, v. 283, p. 684-721.

Zehnder, A.T. and Allmendinger, R.W., 2000, Velocity field for the trishear model. 

Journal of Structural Geology, v. 22, p. 1009-1014.


43


	Trishear3D v. 7.1
	By Nestor Cardozo (University of Stavanger)
	© 2021
	Table of contents
	Disclaimer
	Referencing this program
	Credits
	Introduction
	Basic interface
	Making a model
	Running a model
	Visualizing a model
	Refining a model
	Lateral propagation
	Backlimb kinematics
	Irregular surfaces
	Tables and log
	Keyboard shortcuts
	Algorithms
	References

